You must have Javascript enabled to see this content.

 

Important Message for OverDrive's Libby App Users!

Changes to Libby and OverDrive websites!

Last month, OverDrive reported that the web certificate provider would end support for older operating systems at the end of September 2021. Libby’s minimum iOS version is now iOS 10. To use Libby on an iOS device, users are required to update their device’s operating system to iOS 10 or newer. Click here to access the steps to help iOS users update their operating system version.

Users on legacy web browsers may experience issues loading libbyapp.com or your OverDrive website and should upgrade to a newer browser version, if possible. The
expectation was that affected users would receive a security warning after the web certificate provider's change, but we’ve since learned that a warning is not always displayed. Users may experience issues with signing in, borrowing, loading the app’s content, etc.